Research1 in 10 popular npm releases needed a hotfix

critical vulnerability

Qiskit allows arbitrary code execution decoding QPY format versions < 13

Published Mar 14, 2025 · updated Nov 4, 2026

What to do

  1. Upgrade to a fixed version: qiskit 1.4.2, qiskit 2.0.0rc2.
  2. Some affected packages have no fixed version yet: follow the advisory for mitigations and watch this page for the fix.
  3. Redeploy and restart long-running processes so they load the fixed code.

Affected packages

qiskit-terra

>= 0.18.0, <= 0.46.3
no fix yet

Check your project: pip show qiskit-terra

qiskit

<= 1.4.1
1.4.2

Check your project: pip show qiskit

qiskit

= 2.0.0rc1
2.0.0rc2

Check your project: pip show qiskit

Sources

← All critical vulnerabilities