ExploitedPHP2Shell is now on CISA KEV

critical vulnerability

dcap-qvl has Missing Verification for QE Identity

Published Jan 26, 2026 · updated Oct 27, 2026

What to do

  1. Upgrade to a fixed version: dcap-qvl 0.3.9, @phala/dcap-qvl 0.3.9, dcap-qvl 0.3.9.
  2. Some affected packages have no fixed version yet: follow the advisory for mitigations and watch this page for the fix.
  3. Redeploy and restart long-running processes so they load the fixed code.

Affected packages

dcap-qvl

< 0.3.9
0.3.9

Check your project: cargo tree -i dcap-qvl

@phala/dcap-qvl

<= 0.3.0
0.3.9

Check your project: npm ls @phala/dcap-qvl --all

Is @phala/dcap-qvl@0.3.9 safe to install? See the upgrade verdict →

@phala/dcap-qvl-web

<= 0.3.3
no fix yet

Check your project: npm ls @phala/dcap-qvl-web --all

@phala/dcap-qvl-node

<= 0.3.3
no fix yet

Check your project: npm ls @phala/dcap-qvl-node --all

dcap-qvl

< 0.3.9
0.3.9

Check your project: pip show dcap-qvl

Sources

← All critical vulnerabilities