ExploitedPHP2Shell is now on CISA KEV

critical vulnerability

Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

Published Oct 22, 2026 · updated Oct 23, 2026

What to do

  1. Upgrade to a fixed version: brotli 1.2.1, brotlicffi 1.2.1.0.
  2. Redeploy and restart long-running processes so they load the fixed code.

Affected packages

brotli

>= 1.0.3, < 1.2.1
1.2.1

Check your project: pip show brotli

brotlicffi

>= 1.0.3, < 1.2.1.0
1.2.1.0

Check your project: pip show brotlicffi

What changed

  1. Published in the GitHub Advisory Database as critical.

Sources

← All critical vulnerabilities