ExploitedPHP2Shell is now on CISA KEV

critical vulnerability

LangChain serialization injection vulnerability enables secret extraction in dumps/loads APIs

Published Dec 23, 2025 · updated Oct 27, 2026

What to do

  1. Upgrade to a fixed version: langchain-core 1.2.5, langchain-core 0.3.81.
  2. Redeploy and restart long-running processes so they load the fixed code.

Affected packages

langchain-core

>= 1.0.0, < 1.2.5
1.2.5

Check your project: pip show langchain-core

langchain-core

< 0.3.81
0.3.81

Check your project: pip show langchain-core

Sources

← All critical vulnerabilities