ExploitedPHP2Shell is now on CISA KEV

critical vulnerability

Laravel TokenGuard authentication bypass through non-string API credentials

Published Oct 23, 2026 · updated Oct 23, 2026

What to do

  1. Upgrade to a fixed version: laravel/framework 13.29.0, laravel/framework 12.68.0.
  2. Redeploy and restart long-running processes so they load the fixed code.

Affected packages

laravel/framework

>= 13.0.0, < 13.29.0
13.29.0

Check your project: composer show laravel/framework

laravel/framework

< 12.68.0
12.68.0

Check your project: composer show laravel/framework

What changed

  1. Published in the GitHub Advisory Database as critical.

Sources

← All critical vulnerabilities