Research1 in 10 popular npm releases needed a hotfix

critical vulnerability

protobufjs has an arbitrary code execution issue

Published Apr 16, 2026 · updated Nov 4, 2026

What to do

  1. Upgrade to a fixed version: protobufjs 8.0.1, protobufjs 7.5.5, protobufjs 6.11.6.
  2. Redeploy and restart long-running processes so they load the fixed code.

Affected packages

protobufjs

>= 8.0.0, < 8.0.1
8.0.1

Check your project: npm ls protobufjs --all

Is protobufjs@8.0.1 safe to install? See the upgrade verdict →

protobufjs

>= 7.0.0, < 7.5.5
7.5.5

Check your project: npm ls protobufjs --all

Is protobufjs@7.5.5 safe to install? See the upgrade verdict →

protobufjs

< 6.11.6
6.11.6

Check your project: npm ls protobufjs --all

Is protobufjs@6.11.6 safe to install? See the upgrade verdict →

Sources

← All critical vulnerabilities