Research1 in 10 popular npm releases needed a hotfix

critical vulnerability

Apache IoTDB has a Path Traversal vulnerability

Published Jun 26, 2026 · updated Nov 3, 2026

What to do

  1. Upgrade to a fixed version: org.apache.iotdb:iotdb-server 2.0.6, org.apache.iotdb:iotdb-server 1.3.6.
  2. Redeploy and restart long-running processes so they load the fixed code.

Affected packages

org.apache.iotdb:iotdb-server

>= 2.0.0, < 2.0.6
2.0.6

Check your project: mvn dependency:tree -Dincludes=org.apache.iotdb:iotdb-server

org.apache.iotdb:iotdb-server

>= 1.0.0, < 1.3.6
1.3.6

Check your project: mvn dependency:tree -Dincludes=org.apache.iotdb:iotdb-server

Sources

← All critical vulnerabilities